Follow

Compatibility with macOS High Sierra 10.13

VideoDrive 3.6 is fully compatible with macOS High Sierra 10.13

VideoDrive 3.6 and higher are fully compatible with macOS High Sierra (10.13),macOS Sierra (10.12), OS X El Capitan (10.11). We are no longer officially supporting macOS Yosemite (10.10) and Mavericks (10.9) although VideoDrive 3.6 should still run fine. When upgrading to macOS High Sierra, you should also update VideoDrive to version 3.6 or higher. Also, make sure to run at least iTunes 12.5.1.21 on macOS High Sierra.

VideoDrive 3.6 is now available in from our download page. 

Read the Release Notes.

 

Important warning: if you already upgraded macOS High Sierra and are running an older version of VideoDrive, automatic inline updating will most likely not be possible due to tightened security measurements in the latest macOS release. If you get an error that updating failed, simply download VideoDrive manually from our download page instead. Updating to future updates will be possible again as VideoDrive 3.6 fully complies with all new security rules.

 

 

What about older versions?

VideoDrive 3.5 and earlier are not meant to run on macOS High Sierra.
VideoDrive 2.x will no longer receive any updates and is no longer supported.

 

 

0 Comments

Please sign in to leave a comment.
Powered by Zendesk